Here framework support was removed because of RN60, but now it seems everything working with RN60

https://github.com/invertase/react-native-firebase/commit/f429699990b6d521d996479f2bed96b52bbdb8d8#diff-ae0566325908bcca49c1f88c5223f4e5

Please enable framework support for swift