cc https://github.com/invertase/react-native-firebase/issues/1133

Some of you may have noticed that AdMob now requires to implement the consent-library to get in app consent from users.

(if you are based in the EU this is required for all users)

Google eu-consent documentation:

Android: https://developers.google.com/admob/android/eu-consent

IOS: https://developers.google.com/admob/ios/eu-consent

On a first look these libraries look buggy, also we know that they were written under a huge time pressure.

Is there any plan to implement the eu-consent library in RNFirebase?

How do you tackle this issue? it has been only a few days since this requirement started showing in AdMob and eCPM dropped immediately to about 30% of the usual rate.